Sonntag, 27. April 2014

Warum kam denn nix?

Warum habe ich denn solange nichts mehr geschrieben? Wo war ich denn?
Dafür gibt es mehrere Gründe.

Zum einen hatte ich die erste Zeit viele Klausuren vor den Osterferien und habe dementsprechend entweder etwas für die Schule gemacht oder habe mich bei anderen Sachen entspannt, wie zum Beispiel bis spät in die Nacht irgendeinen unnützen Quatsch programmiert.

Dann haben die Ferien angefangen und ich habe die meiste Zeit entspannt oder mit ein paar Freunden draußen Basketball gespielt, was eigentlich schon fast jeden Samstag Standard ist.

Dazu kam dann noch, dass ich ein bisschen mit meinem Chromebook herumgespielt habe und plötzlich Unity bzw. XFCE nicht mehr starten wollte. Woran lag es?
Ich hatte mir einen Autostart angelegt, der den conky-Systemmonitor startet, denn ich bin oft zu faul den manuell zu starten, allerdings fand das mein Chromebook nicht ganz so nice und hat dann halt einfach beim starten der Benutzeroberfläche gestreikt und es blieb beim grauen Bildschirm, solange bis ich dann das Chromebook neugestartet habe und der ganze Spaß von neu begann.

Was ich gemacht habe? Nein, ich habe nicht bein Starten die Leertaste gedrückt gehalten und deswegen auch nicht mit crouton etwas neues installieren. Nein, ich habe dann versucht in der Shell das /home/-Verzeichnis meines Google-Accounts auf dem Chromebook zu finden was sich als echt schwierig erwiesen hat. Ich hatte echt naiverweise gedacht, dass das Verzeichnis das von dem Verzeichnis-Baum entspräche, aber so ist das nicht.

Nach langer Herumspielerei habe ich es dann endlich gefunden :) Wer es wissen will, es befindet sich im Verzeichnis:
/usr/local/chroots/precise/home/
Später ist mir dann auch aufgefallen, dass ja chroots benutzt wurde. Jedenfalls habe ich das dann alles rückgängig gemacht und alles war wieder in Ordnung.

Weiter im Text. Dann war Ostern und danach habe ich ich mit einem Bauteil herumgeschlagen, das ich mir im Internet bestellt hatte. Ein SainSmart 1.8'' TFT LCD Display mit SDCard-Slot.
Das war beim ersten Anschauen sehr nett, zwar klein, aber sind halt nur 1.8''. Allerdings haben sich ein paar Mängel später herausgestellt, die nicht sehr toll sind :(
Zu allererst, die Montierungen sind sehr schlecht angebracht, das Display kann man sehr leicht verbiegen, was allerdings nicht sehr ratsam ist. Dann habe ich versucht, das Display mit den Bibliotheken von SainSmart zu programmieren, was aber wegen vielen Fehlern innerhalb der Dateien fehlschlug. Dann habe ich die Von Adafruit genommen, Adafruit_GFX und Adafruit_ST7735. Da habe ich dann den graphicstest_highspeed.pde benutzt, was aber kein Resultat gebracht hat.
Es hat sich trotz richtiger Verkabelung nichts getan und auch als ich mir ein paar Skripte selbst zusammengestellt habe ist einfach nichts passiert.

Ich habe dann mal im offiziellen Arduino-Forum angefragt und auch dort waren dann die Antworten so, dass sich schnell herausgestellt hat, dass das TFT Display einfach nur defekt ist, denn nichts hat funktioniert, nicht einmal das Ansprechen der SDKarte hat funktioniert.
Also wird es jetzt weggeschickt, Amazon meint zwar man kann irgendwie keinen Ersatz schicken, aber ich würde gerne noch einmal das gleiche haben, denn es hat die richtige Größe, der SD-Slot ist sehr gut und der Preis war auch echt günstig.
Ich hoffe das nächste wird einwandfrei funktionieren ;)

Und morgen geht für mich dann auch schon wieder die Schule los, also bis dahin,
Tschau mit Vau :D

Liebe Grüße,
~Hubble